• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

QUESTION Compatability with themes

jazzminus

New member
Messages
3
Likes
0
Points
1
#1
Hi,

I have been using your plugin for a long time. Currently I am using version 1.3 with a theme called Modernize. Now I want to switch to a better theme. I tried Insert PHP with the Enfold theme and it didn't work (nothing was displayed). I am wondering why. Also I thought about switching to Avada theme. Is the plugin compatible with it? The theme authors couldn't tell me in advance.

So my question is: is the Insert PHP plugin compatible with Enfold and Avada? What does it generally depend on if it works with a theme?

Thank you in advance
Jasmin
 

Kirill

Support team
Staff member
Messages
80
Likes
4
Points
8
#2
Hi Jasmin

Maybe you use the theme-specific functions in your php?
Please copy your code here.

Best regards, Kirill
Webcraftic team
 

jazzminus

New member
Messages
3
Likes
0
Points
1
#3
Hi Kirill,

the code is:
Code:
[insert_php]
include "https://notdienste-app.herokuapp.com/";
[/insert_php]
I also tried defining the function in functions.php
Code:
function pythonPage()
{
    $url = "https://notdienste-app.herokuapp.com/";
    include $url;
}
and just calling it in the post with
Code:
[insert_php]
pythonPage();
[/insert_php]
but neither works.

Best Regards
Jasmin
 

Kirill

Support team
Staff member
Messages
80
Likes
4
Points
8
#4
Hi Jasmin

Please try the code below

PHP:
[insert_php]
if(ini_get('allow_url_fopen')){
   echo file_get_contents('https://notdienste-app.herokuapp.com/');
}else{
  echo 'Cannot connect: allow_url_fopen is false';
}
[/insert_php]
Best regards, Kirill
Webcraftic team