• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

RESOLVED Automatic space after shortcode

sylvaing

New member
Messages
2
Likes
0
Points
0
#1
Hello,

I created a snippet in order to give a class to some keywords:
PHP:
<span class="mot-cle"><?php echo $contenu ?></span>
When I use it on a word before a punctuation, for example here:
HTML:
Il existe 3 fonctions trigonométriques : [wbcr_snippet id="93161" title="Mot-clé" contenu="sinus"], [wbcr_snippet id="93161" title="Mot-clé" contenu="cosinus"], et [wbcr_snippet id="93161" title="Mot-clé" contenu="tangente"]. Comme la fonction tangente découle des deux premières, c'est sur sinus et cosinus que l'on porte le plus d'attention. Dans la plupart des programmes, seules [latex] \sin [/latex] et [latex] \cos [/latex] font partie du cours et [latex] \tan [/latex] est vue en exercice.
a space automatically appear between the word and the punctuation, as you can see in the attached file. Have you an idea how to disable this automatic space?

Thank you for your help.

P.S.: I love your plugin, it's very useful for my website!!
 

Attachments

Temyk

Support team
Staff member
Messages
186
Likes
12
Points
18
#2
Hi.

The universal snippet adds spaces before and after. You can use PHP snippet - there are no spaces.
PHP:
?><span class="mot-cle"><?php echo $contenu ?></span><?php
We will fix this in the next update.
 
Last edited: