• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

BUG Frontend submission don't generate featured images

Messages
5
Likes
0
Points
1
#1
Hello,

i have a Theme with Custom Post type. Users can submit posts in the frontend. But the generation of the featured image don't work.

If i edit the Post in Backend and save it again, it work.

Can you help me?
 

Temyk

Developer & Support
Staff member
Messages
745
Likes
32
Points
28
#2
Hello.

The plugin works when adding news via the admin panel. A hook is used for this purpose.
This hook doesn't work when adding news on the frontend. If you can modify the theme code, I'll tell you what hook to use.
 
Messages
5
Likes
0
Points
1
#4
Hello.

The plugin works when adding news via the admin panel. A hook is used for this purpose.
This hook doesn't work when adding news on the frontend. If you can modify the theme code, I'll tell you what hook to use.
Can you please tell me?
 

Temyk

Developer & Support
Staff member
Messages
745
Likes
32
Points
28
#5
You need to add posts using standard WordPress functions.
 
Messages
5
Likes
0
Points
1
#8
That doesn't help! You sell a Plugin, that should generate Image of Custom Post Types. But it doesn't work! Thats not ok.

The Image will generate in Background but not link with the Post.

Your wp_insert_post() don't help for that......

Great Support! You get Money but do nothing.....
 

Temyk

Developer & Support
Staff member
Messages
745
Likes
32
Points
28
#9
Our plugin supports custom post types, and can automatically generate images of posts when you add them via the admin panel. But the plugin has don't know how you add frontend posts in your theme. I wrote to you that you need to use the wp_insert_post function. The plugin uses the save_post hook that is called in this function.

The plugin also has generation settings, check what is selected there.